Instalasi Laravel 5.7

Sebelum menginstal laravel pada server ada, Anda harus memastikan server Anda memenuhi persyaratan berikut:

  • PHP >= 7.1.3
  • OpenSSL PHP Extension
  • PDO PHP Extension
  • Mbstring PHP Extension
  • Tokenizer PHP Extension
  • XML PHP Extension
  • Ctype PHP Extension
  • JSON PHP Extension

laravel menggunakan Composer untuk mengelola dependensinya. Jadi, sebelum menggunakan Laravel, pastikan Anda memiliki Composer yang terpasang di komputer Anda.

Download Composer

Cara 1: Via Installer Laravel

pertama download installer laravel

composer global require laravel/installer

kemudian jalankan perintah berikut pada composer

laravel new blog

Cara 2: Via composer create-project.

Setelah Anda berhasil menginstall composer, cukup jalankan perintah berikut ini di terminal/console/command prompt Anda:

composer create-project laravel/laravel blog --prefer-dist

Best Of The Week